Nieuws:

Help mee aan het verbeteren van het forum via een donatie. Klik hier,

Hoofdmenu


Er gaat iets fout met links

Gestart door JanDeGraaff, 23-09-2022 17:19 u

Vorige topic - Volgende topic

0 leden en 1 gast bekijken dit topic.

JanDeGraaff

Het lijkt erop dat er soms iets fout gaat in het forum met de links die bijgevoegd worden. Soms verwijzen ze naar een compleet ander adres dan wat opgegeven is. Dit lijkt voornamelijk te gebeuren met links die met de knop "Voeg een link toe" aan een stukje tekst worden toegevoegd.

In dit topic/bericht staat een voorbeeld: https://www.hobbybrouwen.nl/forum/index.php?msg=672286

[edit] Ik kan het, helaas, hier nu niet reproduceren. De twee bovenstaande links zijn voor mij identiek na opslaan.. [/edit]

Jacques

Citaat van: JanDeGraaff op 23-09-2022  17:19 uHet lijkt erop dat er soms iets fout gaat in het forum met de links die bijgevoegd worden. Soms verwijzen ze naar een compleet ander adres dan wat opgegeven is. Dit lijkt voornamelijk te gebeuren met links die met de knop "Voeg een link toe" aan een stukje tekst worden toegevoegd.

In dit topic/bericht staat een voorbeeld: https://www.hobbybrouwen.nl/forum/index.php?msg=672286

[edit] Ik kan het, helaas, hier nu niet reproduceren. De twee bovenstaande links zijn voor mij identiek na opslaan.. [/edit]

Het lukt mij niet om dit te reproduceren. Ook heb ik dit probleem nooit eerder ervaren.

JanDeGraaff

Het is ook heel raar. Het gebeurd mij heel af en toe.
Ik had het een paar dagen geleden ook, toen ik een link postte. Toen ik de link, nadat ik het bericht verzonden had, probeerde, ging ie heel ergens anders naar toe. Ik dacht dat het aan mijn geplakte link lag en opende mijn bericht om te veranderen. Toen bleek dat de link die ik geplakt had, prima was. Na opnieuw het bericht opgeslagen te hebben was hij inderdaad goed.

Maar gisteren dus weer en had ook @Ron H er last van. En vlak daarna ik ook weer.
Maar later weer niet meer.

Omdat ik de link naar de genoemde PDF nooit eerder gezien noch ooit eerder geopend heb, kan het, volgens mij, geen browser (cache) probleem zijn.

Heel gek...

Als het mij weer eens gebeurd zal ik er een screenshot van maken.

Jacques

Vreemd.

Ook omdat de laatste tijd niets is veranderd aan de software van het forum.
Misschien ligt het toch aan het cache geheugen. Als je weer ziet ververst dan de pagina met Ctrl+F5.

JanDeGraaff

Citaat van: Jacques op 24-09-2022  14:56 uVreemd.
[...]
Misschien ligt het toch aan het cache geheugen.
Vreemd zeker, maar een computer kan niet een link verzinnen waar het niet eerder is geweest.
De link naar de PDF heb ik nooit eerder gezien, laat staan ooit geopend. En mijn laptop is drie weken oud, dus dat weet ik 100% zeker. Die link zat niet in mijn cache.

De geserveerde link lijkt eerder uit de cache van de forum software te komen, waarbij er iets in de achtergrond mis gaat met de omzetting van de [url] code naar een valide HTML link.

De pagina verversen lost het wellicht op, maar dat is symptoom bestrijding. Wellicht dat er een bug in SMF zit. Ron H had het probleem ook, ik ben dus niet de enige. Ik meld het alleen even.

Wijbrouwers

Citaat van: Jacques op 23-09-2022  22:05 uHet lukt mij niet om dit te reproduceren. Ook heb ik dit probleem nooit eerder ervaren.

Niet zeikerig bedoeld maar je bent dit eerder tegen gekomen in Dit topic over het motoriseren van de walsenmolen.
Het lijkt er op dat heel soms de eerste keer dat je op een URL klikt de redirect verkeerd gaat. Vanaf dat moment gaat het dan weer goed. Mijn vermoeden ligt dat dit aan de cache van de browser of van het forum. Dat daar dan nog wat instaat waardoor de redirect verkeerd gaat. Hoe dit op te lossen weet  ik helaas niet.

JanDeGraaff

Citaat van: Wijbrouwers op 24-09-2022  23:46 uNiet zeikerig bedoeld maar je bent dit eerder tegen gekomen in Dit topic over het motoriseren van de walsenmolen.

Sterker: Ik had het in dat topic – toen ik net ging kijken – zelf ook, kijk maar naar het screenshot hieronder. Als ik met mijn muis over de link "deze site" ging, verwees het forum mij naar "draughtquality.org/FrontPage" en niet naar een pagina op kabelshop.nl, zoals de bedoeling was.
En die draughtquality.org link komt duizend procent niet uit mijn browser's cache.

Pas toen ik de pagina herlaadde (ctrl + R) verwees de link correct.
Ik weet ook niet wat er mis gaat, maar ik heb het bij deze gemeld. Wellicht dat het bekend is bij SMF en komt er eerdaags een oplossing.

Screenshot 2022-09-25 at 10.55.16.png

Jacques

Citaat van: Wijbrouwers op 24-09-2022  23:46 uNiet zeikerig bedoeld maar je bent dit eerder tegen gekomen in Dit topic over het motoriseren van de walsenmolen.
Het lijkt er op dat heel soms de eerste keer dat je op een URL klikt de redirect verkeerd gaat. Vanaf dat moment gaat het dan weer goed. Mijn vermoeden ligt dat dit aan de cache van de browser of van het forum. Dat daar dan nog wat instaat waardoor de redirect verkeerd gaat. Hoe dit op te lossen weet  ik helaas niet.

Nu je het zegt. Voor mij was dit onbegrijpelijk. En omdat het incidenteel karakter had heb ik verder geen acht op geslagen. Mogelijk komt dit door de versneller van het cachegeheugen van het forum. Ik zal eens kijken of daar wat aan te veranderen valt. Daar ben ik overigens heel voorzichtig mee omdat dit ertoe kan leiden dat het forum niet meer werkt.

Vergelijkbare Topics (7)

13061

Reacties: 23
Gelezen: 10933

31361

Reacties: 106
Gelezen: 51616

44410

Reacties: 4
Gelezen: 530

10915

Reacties: 24
Gelezen: 14121

44726

Reacties: 2
Gelezen: 948


Zoeken met Google op deze site.
Brouwspullen zijn ook te koop via Bol.com.
Als je iets bestelt bij Bol.com (ook andere zaken dan brouwspullen) via deze link steun je het forum.


Het boek van de beheerder van deze site.