Hoe plaats je een foto op dit forum, klik hier voor nadere uitleg.

Steun het forum. Koop via deze links: Nederlandstalige bierboeken, Engelstalige bierboeken, een bierig artikel of een ander artikel van bol.com

Auteur Topic: Craftbeepi3 installatiefout gitdb  (gelezen 136 keer)

0 leden en 1 gast bekijken dit topic.

Offline Woeka

  • Eerste berichten geplaatst
  • *
  • Berichten: 8
  • Land: nl
  • ... whatever
Craftbeepi3 installatiefout gitdb
« Gepost op: 16-09-2020 13:13 u »
Ik heb hier een nieuwe installatie gedaan van de craftbeerpi3 software op een Raspberry Pi (fresh install met desktop versie zonder extra's). Aangezien dat niet helemaal volgens plan verliep en er vast meer mensen tegenaan gaan lopen hier op oplossing.

Mijn installatie van Craftbeerpi3 gaf de onderstaande foutmelding:
Collecting gitdb>=4.0.1 (from gitdb2>=2.0.0->GitPython==2.1.3->-r requirements.txt (line 14))
Using cached https://www.piwheels.org/simple/gitdb/gitdb-4.0.1-py2.py3-none-any.whl
gitdb requires Python '>=3.4' but the running Python is 2.7.16

Eerst geprobeerd op craftbeerpi3 op een nieuwe versie van Puyhton 3.7 te laten draaien. Dat leverde meer andere problemen op, dus terug naar Python2.7.
De uiteindelijke oplossing is het installeren van GitPyhton 2.1.15

Na verder zoeken bleek dat er al een draadje over was: https://github.com/Manuel83/craftbeerpi3/pull/251
De regel in het bestand "requirements.txt" met GitPython==2.1.3 aanpassen naar GitPython==2.1.15 zou ook moeten werken, daarna nogmaals de installatie draaien.

Tags: